Browser Check
The OilSim application supports the following browsers. Firefox 44+, Internet Explorer 9.0+ and Chrome 48+.

Although all these browsers are supported, OilSim is optimized for Mozilla Firefox.

Adobe Flash is not required to run OilSim but it provides a better experience. The minimum version is Adobe Flash 9.0+
Checking...
Checking...
Region Status
US West - Northern California
EU - Ireland
Asia Pacific - Singapore